Issues creating new Audits
Incident Report for Falcony
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 21:19 EET
Monitoring
We have rolled back the release that caused this issue. We are now monitoring the situation.
Posted Mar 20, 2024 - 15:31 EET
Investigating
We're currently investigating an issue that is preventing new audits from being created.
Posted Mar 20, 2024 - 15:15 EET
This incident affected: Falcony.